IOmeter 1.1.0 for ubuntu-16.04-server-ppc64le

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

IOmeter 1.1.0 for ubuntu-16.04-server-ppc64le

weihua.zhu@powercore.com.cn
Hi IOmeter

 I can not complie iometer-1.1.0-src on ubuntu16.04-server-ppc64le.
Configure:
OS type: ubutu16.04-server for ppc64le
gcc is already the newest version (4:5.3.1-1ubuntu1)

Step:
root@ubuntu:~/iometer-1.1.0/src# cp Makefile-Linux.ppc Makefile
root@ubuntu:~/iometer-1.1.0/src# make all
/usr/bin/g++ -O3 -Wall -D_GNU_SOURCE -DIOMTR_OSFAMILY_UNIX -DIOMTR_OS_LINUX -DIOMTR_CPU_PPC -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DUSE_NEW_DISCOVERY_MECHANISM -DFORCE_STRUCT_ALIGN -c Pulsar.cpp
In file included from Pulsar.cpp:135:0:
/usr/include/c++/5/bits/sstream.tcc: In member function ‘virtual std::__cxx11::basic_stringbuf<_CharT, _Traits, _Alloc>::int_type std::__cxx11::basic_stringbuf<_CharT, _Traits, _Alloc>::overflow(std::__cxx11::basic_stringbuf<_CharT, _Traits, _Alloc>::int_type)’:
IOCommon.h:1041:33: error: expected unqualified-id before ‘(’ token
    #define max(a,b)             (((a) > (b)) ? (a) : (b))
                                 ^
IOCommon.h:1044:33: error: expected unqualified-id before ‘(’ token
    #define min(a,b)             (((a) < (b)) ? (a) : (b))
                                 ^
Makefile:143: recipe for target 'Pulsar.o' failed
make: *** [Pulsar.o] Error 1

 Ask:
    do you have any suggestion for me?
Thanks


Weihua Zhu (朱卫华)
System Department
Tel: +86-512-68316328
Phone:13812765084

------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
_______________________________________________
Iometer-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/iometer-user
Reply | Threaded
Open this post in threaded view
|

Re: IOmeter 1.1.0 for ubuntu-16.04-server-ppc64le

Jose Medeiros-2
I am not sure which dependency is causing your error, " In file included from Pulsar.cpp:135:0 "
I don't think this guy got an answer either.
https://sourceforge.net/p/iometer/mailman/iometer-user/thread/OFA5511E29.5115DDD3-ONC1257D89.0053A3F2-C1257D89.0053C661@.../


Let me ask a dumb question, why are you using a PowerPC is it a Power Mac G5 ?


 
Sincerely, Jose F. Medeiros ,  408-256-0649 Google Voice
San Jose, California
http://www.linkedin.com/in/josemedeiros
I have not failed. I've just found 10,000 ways that won't work. - Thomas A. Edison





From: "[hidden email]" <[hidden email]>
To: iometer-user <[hidden email]>
Sent: Thursday, March 9, 2017 1:45 AM
Subject: [Iometer-user] IOmeter 1.1.0 for ubuntu-16.04-server-ppc64le

Hi IOmeter

 I can not complie iometer-1.1.0-src on ubuntu16.04-server-ppc64le.
Configure:
OS type: ubutu16.04-server for ppc64le
gcc is already the newest version (4:5.3.1-1ubuntu1)

Step:
root@ubuntu:~/iometer-1.1.0/src# cp Makefile-Linux.ppc Makefile
root@ubuntu:~/iometer-1.1.0/src# make all
/usr/bin/g++ -O3 -Wall -D_GNU_SOURCE -DIOMTR_OSFAMILY_UNIX -DIOMTR_OS_LINUX -DIOMTR_CPU_PPC -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DUSE_NEW_DISCOVERY_MECHANISM -DFORCE_STRUCT_ALIGN -c Pulsar.cpp
In file included from Pulsar.cpp:135:0:
/usr/include/c++/5/bits/sstream.tcc: In member function ‘virtual std::__cxx11::basic_stringbuf<_CharT, _Traits, _Alloc>::int_type std::__cxx11::basic_stringbuf<_CharT, _Traits, _Alloc>::overflow(std::__cxx11::basic_stringbuf<_CharT, _Traits, _Alloc>::int_type)’:
IOCommon.h:1041:33: error: expected unqualified-id before ‘(’ token
    #define max(a,b)             (((a) > (b)) ? (a) : (b))
                                 ^
IOCommon.h:1044:33: error: expected unqualified-id before ‘(’ token
    #define min(a,b)             (((a) < (b)) ? (a) : (b))
                                 ^
Makefile:143: recipe for target 'Pulsar.o' failed
make: *** [Pulsar.o] Error 1

 Ask:
    do you have any suggestion for me?
Thanks


Weihua Zhu (朱卫华)
System Department
Tel: +86-512-68316328
Phone:13812765084
------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford_______________________________________________
Iometer-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/iometer-user



------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
_______________________________________________
Iometer-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/iometer-user
Reply | Threaded
Open this post in threaded view
|

Re: IOmeter 1.1.0 for ubuntu-16.04-server-ppc64le

weihua.zhu@powercore.com.cn
Hi jose
    We use IBM Power8 CPU.
1. Makefile_Linux.ppc can support power8 planform server?
2. IOmeter-1.1.0 can complie on ubuntu16.04-server-ppc64le successfully?
3. I follow this bug and undefine max and min and can complie successfully,but when I dynamo to win64 and run program will show error info.
Note: I try this under iometer-2006_07_27.common-src.(I use iometer-1.1.0-src again, 1.1.0 can not run, so do not show this error info.)

Weihua Zhu (朱卫华)
System Department
Tel: +86-512-68316328
Phone:13812765084
 
Date: 2017-03-10 07:24
Subject: Re: [Iometer-user] IOmeter 1.1.0 for ubuntu-16.04-server-ppc64le
I am not sure which dependency is causing your error, " In file included from Pulsar.cpp:135:0 "
I don't think this guy got an answer either.
https://sourceforge.net/p/iometer/mailman/iometer-user/thread/OFA5511E29.5115DDD3-ONC1257D89.0053A3F2-C1257D89.0053C661@.../


Let me ask a dumb question, why are you using a PowerPC is it a Power Mac G5 ?


 
Sincerely, Jose F. Medeiros ,  408-256-0649 Google Voice
San Jose, California
http://www.linkedin.com/in/josemedeiros
I have not failed. I've just found 10,000 ways that won't work. - Thomas A. Edison





From: "[hidden email]" <[hidden email]>
To: iometer-user <[hidden email]>
Sent: Thursday, March 9, 2017 1:45 AM
Subject: [Iometer-user] IOmeter 1.1.0 for ubuntu-16.04-server-ppc64le

Hi IOmeter

 I can not complie iometer-1.1.0-src on ubuntu16.04-server-ppc64le.
Configure:
OS type: ubutu16.04-server for ppc64le
gcc is already the newest version (4:5.3.1-1ubuntu1)

Step:
root@ubuntu:~/iometer-1.1.0/src# cp Makefile-Linux.ppc Makefile
root@ubuntu:~/iometer-1.1.0/src# make all
/usr/bin/g++ -O3 -Wall -D_GNU_SOURCE -DIOMTR_OSFAMILY_UNIX -DIOMTR_OS_LINUX -DIOMTR_CPU_PPC -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DUSE_NEW_DISCOVERY_MECHANISM -DFORCE_STRUCT_ALIGN -c Pulsar.cpp
In file included from Pulsar.cpp:135:0:
/usr/include/c++/5/bits/sstream.tcc: In member function ‘virtual std::__cxx11::basic_stringbuf<_CharT, _Traits, _Alloc>::int_type std::__cxx11::basic_stringbuf<_CharT, _Traits, _Alloc>::overflow(std::__cxx11::basic_stringbuf<_CharT, _Traits, _Alloc>::int_type)’:
IOCommon.h:1041:33: error: expected unqualified-id before ‘(’ token
    #define max(a,b)             (((a) > (b)) ? (a) : (b))
                                 ^
IOCommon.h:1044:33: error: expected unqualified-id before ‘(’ token
    #define min(a,b)             (((a) < (b)) ? (a) : (b))
                                 ^
Makefile:143: recipe for target 'Pulsar.o' failed
make: *** [Pulsar.o] Error 1

 Ask:
    do you have any suggestion for me?
Thanks


Weihua Zhu (朱卫华)
System Department
Tel: +86-512-68316328
Phone:13812765084
------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford_______________________________________________
Iometer-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/iometer-user



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Iometer-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/iometer-user

make all.txt (15K) Download Attachment
vim IOCommon.h.txt (396 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: IOmeter 1.1.0 for ubuntu-16.04-server-ppc64le

weihua.zhu@powercore.com.cn
Hi jose
    We use IBM Power8 CPU.
1. Makefile_Linux.ppc can support power8 planform server?
2. IOmeter-1.1.0 can complie on ubuntu16.04-server-ppc64le successfully?
3. I follow this bug and undefine max and min and can complie successfully,but when I dynamo to win64 and run program will show error info.
Note: I try this under iometer-2006_07_27.common-src.(I use iometer-1.1.0-src again, 1.1.0 can not run, so do not show this error info.)


Weihua Zhu (朱卫华)
System Department
Tel: +86-512-68316328
Phone:13812765084
 
Date: 2017-03-10 07:24
Subject: Re: [Iometer-user] IOmeter 1.1.0 for ubuntu-16.04-server-ppc64le
I am not sure which dependency is causing your error, " In file included from Pulsar.cpp:135:0 "
I don't think this guy got an answer either.
https://sourceforge.net/p/iometer/mailman/iometer-user/thread/OFA5511E29.5115DDD3-ONC1257D89.0053A3F2-C1257D89.0053C661@.../


Let me ask a dumb question, why are you using a PowerPC is it a Power Mac G5 ?


 
Sincerely, Jose F. Medeiros ,  408-256-0649 Google Voice
San Jose, California
http://www.linkedin.com/in/josemedeiros
I have not failed. I've just found 10,000 ways that won't work. - Thomas A. Edison





From: "[hidden email]" <[hidden email]>
To: iometer-user <[hidden email]>
Sent: Thursday, March 9, 2017 1:45 AM
Subject: [Iometer-user] IOmeter 1.1.0 for ubuntu-16.04-server-ppc64le

Hi IOmeter

 I can not complie iometer-1.1.0-src on ubuntu16.04-server-ppc64le.
Configure:
OS type: ubutu16.04-server for ppc64le
gcc is already the newest version (4:5.3.1-1ubuntu1)

Step:
root@ubuntu:~/iometer-1.1.0/src# cp Makefile-Linux.ppc Makefile
root@ubuntu:~/iometer-1.1.0/src# make all
/usr/bin/g++ -O3 -Wall -D_GNU_SOURCE -DIOMTR_OSFAMILY_UNIX -DIOMTR_OS_LINUX -DIOMTR_CPU_PPC -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DUSE_NEW_DISCOVERY_MECHANISM -DFORCE_STRUCT_ALIGN -c Pulsar.cpp
In file included from Pulsar.cpp:135:0:
/usr/include/c++/5/bits/sstream.tcc: In member function ‘virtual std::__cxx11::basic_stringbuf<_CharT, _Traits, _Alloc>::int_type std::__cxx11::basic_stringbuf<_CharT, _Traits, _Alloc>::overflow(std::__cxx11::basic_stringbuf<_CharT, _Traits, _Alloc>::int_type)’:
IOCommon.h:1041:33: error: expected unqualified-id before ‘(’ token
    #define max(a,b)             (((a) > (b)) ? (a) : (b))
                                 ^
IOCommon.h:1044:33: error: expected unqualified-id before ‘(’ token
    #define min(a,b)             (((a) < (b)) ? (a) : (b))
                                 ^
Makefile:143: recipe for target 'Pulsar.o' failed
make: *** [Pulsar.o] Error 1

 Ask:
    do you have any suggestion for me?
Thanks


Weihua Zhu (朱卫华)
System Department
Tel: +86-512-68316328
Phone:13812765084
------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford_______________________________________________
Iometer-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/iometer-user



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Iometer-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/iometer-user