Re: Iometer hangs/gets stuck at the end of the test

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Iometer hangs/gets stuck at the end of the test

Mahendra Ladhe
Hi,
     After debugging a more on the following hang/block issue, I found that
the call to WriteFile in function TargetDisk::Write in file IOTargetDisk.cpp is the one
which gets blocked for 7-8 minutes. After that it returns error code ERROR_IO_PENDING.

This blocking happens only when target disk is network mapped drive and not for local C: drive.
Any ideas/suggestions ?

Thank you,
Mahendra


From: Mahendra Ladhe <[hidden email]>
To: "[hidden email]" <[hidden email]>
Sent: Friday, 22 August 2014 10:31 AM
Subject: Iometer hangs/gets stuck at the end of the test

Hi,
   
Iometer version : 1.1.0 (latest binaries as of 22nd August 2014 downloaded from sourceforge.net)
OS : Windows 7 Enterprise
Access specification : 512B; 75% Read; 0% random,NONE

The disk target is a network mapped drive.

When I run a test with aforementioned specification, at the end of the test, Iometer hangs for a couple of minutes.
After that it says test completed. But the only stat that is updated is "% CPU Utilization".

However, if I use an access specification which has 100% read and no write, then this issue is not seen.

I found that a similar issue was reported by someone in July 2013. 
(http://sourceforge.net/p/iometer/mailman/message/31232946/)
But the reporter was running dynamo on a Linux machine. In my case, dynamo is running on Windows machine only.

I tried using a block size of 4 KB instead of 512 bytes as suggested by someone in aforementioned thread,
but that didn't help.

Could someone please suggest what could be going wrong ?

Thank you,
Mahendra





------------------------------------------------------------------------------
Slashdot TV.  
Video for Nerds.  Stuff that matters.
http://tv.slashdot.org/
_______________________________________________
Iometer-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/iometer-user
Loading...